Now Available: Meltano v1.32.1

Today, we are excited to release Meltano version 1.32.1, which fixes a bug that prevented some Singer taps and targets from working with Meltano because of conflicting Python dependencies.

Many thanks to Zafar Toshpulatov for reporting this bug on Slack. The loader he was trying to use, pipelinewise-target-postgres, should now work without issues. 🙂

To upgrade your local installation of Meltano, activate the appropriate Python virtual environment and run meltano upgrade from inside a Meltano project, or pip3 install --upgrade meltano from anywhere else.


Specifically, version 1.32.1 contains the following changes relative to 1.32.0:

Fixes

  • #2024 Have plugin venvs not inherit Meltano venv to prevent wrong versions of modules from being loaded